Billing page outage
Incident Report for ShopKeep
Resolved
All services have been restored.
Posted about 1 year ago. May 19, 2017 - 13:30 EDT
Identified
Some users may have intermittent issues in gaining access to their account management page. This is due to issues with our third party billing provider. Our engineers are currently monitoring the situation.
Posted about 1 year ago. May 19, 2017 - 13:13 EDT