Customer Care SMS/Text Connectivity
Incident Report for ShopKeep
Resolved
Our SMS/text messaging connectivity issues with our provider are resolved and support is now available via SMS/text.
Posted 4 months ago. Aug 10, 2018 - 17:55 EDT
Investigating
We are currently experiencing connectivity issues for merchants contacting Customer Care via SMS/text messaging. We apologize for the inconvenience and are working with our provider to restore service as soon as possible. Please visit your BackOffice for all other support options and to begin a chat with an advisor.
Posted 4 months ago. Aug 09, 2018 - 19:35 EDT
This incident affected: Support (SMS/Text Messaging).