Issues activating Register
Incident Report for ShopKeep
Resolved
All systems are normal.
Posted 5 months ago. Jun 01, 2017 - 11:45 EDT
Monitoring
All merchants should now be able to activate Registers normally. We are continuing to monitor.
Posted 5 months ago. Jun 01, 2017 - 11:19 EDT
Identified
Many merchants are still having issues activating their Registers; we're investigating the issue.
Posted 5 months ago. Jun 01, 2017 - 10:52 EDT
Monitoring
Some merchants were briefly unable to activate new Registers; our engineers have identified the problem and are monitoring the fix.
Posted 5 months ago. Jun 01, 2017 - 10:32 EDT