Intermittent connection issues for shopkeep.com
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 18 days ago. Jun 28, 2019 - 21:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Jun 28, 2019 - 21:32 EDT
Investigating
We’re currently working with our upstream provider to investigate connection issues to Shopkeep.com.
Posted 18 days ago. Jun 28, 2019 - 19:21 EDT
This incident affected: ShopKeep.com.