BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
The resolution has been fully confirmed and BackOffice performance is back to normal.
Posted 11 months ago. Jan 10, 2018 - 14:29 EST
Investigating
Some ShopKeep users are reporting an inability to access their BackOffice. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 11 months ago. Jan 10, 2018 - 14:03 EST