BackOffice unavailable
Incident Report for ShopKeep
Postmortem

Dear ShopKeep customers,

We take the reliability of our software very seriously and believe that transparency with our customers is key.

On Tuesday, we experienced a significant disruption to a critical part of our infrastructure due to a major outage within Amazon Web Services. Unfortunately, this issue caused our BackOffice to be unavailable for about 5 hours and we apologize for any inconvenience this may have caused you.

We are currently investigating a variety of ways in which we can reduce customer impact if an issue like this occurs again.

The good news is that your ability to use ShopKeep's register app and process sales was not affected in any way by this issue and no data was lost! You may have noticed some delays in transactions posting to BackOffice on Tuesday evening, but these would all have been resolved by Wednesday morning.

We understand how critical your POS is to running your business and wanted to make sure you know that our entire team is focused on ensuring ShopKeep’s continued stability and reliability.

The ShopKeep Team

Posted Mar 02, 2017 - 13:28 EST

Resolved
This incident has been resolved.
Posted Feb 28, 2017 - 19:02 EST
Monitoring
BackOffice services are fully available. ShopKeep engineers are continuing to monitor the stability of our underlying cloud infrastructure.
Posted Feb 28, 2017 - 17:31 EST
Update
BackOffice is currently unavailable due to a major outage within Amazon's cloud computing platform. Amazon have confirmed they are actively working on remediating the issue. ShopKeep engineers are monitoring the services & will restore BackOffice to full service as soon as possible.
Posted Feb 28, 2017 - 15:46 EST
Update
BackOffice is currently unavailable due to a major outage within Amazon's cloud computing platform. Amazon have confirmed they are actively working on remediating the issue. ShopKeep engineers are monitoring the services & will restore BackOffice to full service as soon as possible.
Posted Feb 28, 2017 - 13:22 EST
Update
BackOffice is currently unavailable due to a major outage within Amazon's cloud computing platform. ShopKeep engineers are continuing to investigate.
Posted Feb 28, 2017 - 13:06 EST
Identified
BackOffice is being affected by a problem with the Amazon cloud computing platform. Engineers are continuing to investigate.
Posted Feb 28, 2017 - 13:00 EST
Investigating
We're investigating reports of users being unable to access BackOffice.
Posted Feb 28, 2017 - 12:45 EST