Customer Care Support Line
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 23, 2018 - 01:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 23, 2018 - 01:47 EDT
Update
We have identified an outage with our phone support line. We are working with our provider to get the phone line back up and running. We apologize for the inconvenience. Please reach out to us via chat, sms 877-759-9919 or email support@shopkeep.com for support during this time.
Posted 4 months ago. Aug 23, 2018 - 00:22 EDT
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. Aug 23, 2018 - 00:10 EDT
Identified
We are currently investigating a potential outage to our Customer Care phone support line. We apologize for the inconvenience. Please reach out to us via chat, sms 877-759-9919 or email support@shopkeep.com for support during this time.
Posted 4 months ago. Aug 22, 2018 - 23:55 EDT
This incident affected: Support (Phone).