BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
The resolution has been fully confirmed and BackOffice performance is back to normal.
Posted 10 months ago. Feb 23, 2018 - 12:14 EST
Investigating
Some ShopKeep users are reporting a delay in receiving BackOffice reporting data. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 10 months ago. Feb 23, 2018 - 11:19 EST