Intermittent Processing Issues
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 14, 2016 - 18:06 EST
Investigating
We've received reports from several users of difficulty completing credit card transactions. It's likely that the issue is connected with a specific internet service provider. If you are encountering similar issues, please refer to this page for updates.
Posted 10 months ago. Nov 14, 2016 - 15:26 EST