Issue with toll free number
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 15, 2016 - 12:32 EST
Monitoring
We are receiving calls normally through our main 800 number once more. Due to the way phone carriers work, it may be that some phones still cannot connect with the main number, but that should resolve itself shortly.

If you still have difficulty connecting, feel free to use 646 780 8168 to reach us.
Posted 10 months ago. Nov 15, 2016 - 10:51 EST
Investigating
We are investigating an issue with our main toll free number (800-820-9814) that is preventing calls from connecting properly. In the meantime, callers wishing to reach ShopKeep may dial 646-780-8168, which reaches the same destination as our toll free number.
Posted 10 months ago. Nov 15, 2016 - 09:25 EST