BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
The resolution has been fully confirmed and BackOffice performance is back to normal.
Posted 6 months ago. Mar 30, 2018 - 17:59 EDT
Investigating
Some ShopKeep users are reporting a delay in Back Office reporting. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 6 months ago. Mar 30, 2018 - 17:43 EDT