ShopKeep Customer Care Phone Service
Incident Report for ShopKeep
Resolved
The issues with our phone provider has been resolved. If you need support all channels including phone are available and fully operational. For fastest service please connect with us via Chat by logging into your BackOffice or at your convenience via SMS.
Posted 11 months ago. May 13, 2018 - 16:59 EDT
Update
We are continuing to work on a fix for this issue.
Posted 11 months ago. May 13, 2018 - 09:25 EDT
Identified
We are currently experiencing issues with our phone provider and call wait times may be heavily increased at this time. They are actively working on the issue and we hope to remedy ASAP. Please connect with us via Chat by logging into your BackOffice, SMS, or via email at support@shopkeep.com.
Posted 11 months ago. May 13, 2018 - 08:36 EDT
This incident affected: Support (Phone).