BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 28, 2019 - 17:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Mar 28, 2019 - 17:40 EDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Mar 28, 2019 - 17:38 EDT
Investigating
Some ShopKeep users are reporting an inability to access their BackOffice. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted 5 months ago. Mar 28, 2019 - 17:38 EDT
This incident affected: BackOffice.