Credit Card Processing - Heartland Payment Solutions
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 06, 2019 - 14:56 EDT
Investigating
Merchants utilizing Heartland Payment Solutions are currently experiencing intermittent connectivity, meaning you may see issues processing credit card payments. Please subscribe to updates on this page for new information as we uncover it.
Posted 12 days ago. Sep 06, 2019 - 14:13 EDT
This incident affected: Payment Processing (Credit Cards).