ShopKeep Customer Care Phone Support
Incident Report for ShopKeep
Resolved
The issue with our phone provider has been resolved. Our phone support is fully operational at this time.
Posted 3 months ago. Jan 15, 2018 - 22:00 EST
Update
Issues with our phone provider continue and their escalated engineers continue to work actively on the issue. We hope to resolve as soon as possible! Our Support Team remains available via Chat by logging into your BackOffice, SMS at 877-759-9919, or via email at support@shopkeep.com.
Posted 3 months ago. Jan 15, 2018 - 20:38 EST
Identified
We are currently experiencing issues with our phone provider. They are actively working on the issue and we hope to remedy ASAP. Please connect with us via Chat by logging into your BackOffice, SMS at 877-759-9919, or via email at support@shopkeep.com.
Posted 3 months ago. Jan 15, 2018 - 19:53 EST
Investigating
We've identified an issue with our phone system and are currently investigating. Chat and SMS contact remains operational.
Posted 3 months ago. Jan 15, 2018 - 19:17 EST