BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 05, 2018 - 15:44 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Dec 05, 2018 - 14:40 EST
Identified
The BackOffice is currently experiencing degraded performance. We have identified the issue and we are working to resolve this as soon as possible. Please subscribe to this page for further status updates.
Posted 4 months ago. Dec 05, 2018 - 12:45 EST
This incident affected: BackOffice.