Intermittent Processing Issues
Incident Report for ShopKeep
Resolved
The aforementioned issue appears to have been resolved by the affected ISP.
Posted about 1 year ago. Nov 13, 2016 - 19:42 EST
Investigating
We've received reports from several users of difficulty completing credit card transactions. It's likely that the issue is connected with a specific internet service provider. If you are encountering similar issues, please refer to this page for updates.
Posted about 1 year ago. Nov 13, 2016 - 18:23 EST