Investigating Processing - TSYS
Incident Report for ShopKeep
Resolved
The service issue affecting TSYS merchants has been resolved.
Posted about 1 month ago. Aug 18, 2017 - 17:34 EDT
Investigating
We are currently investigating an issue with merchants processing through TSYS experiencing timeouts and slower than normal processing times when processing credit card transactions. Our Analysts are monitoring this issue and we will update you as soon as this is resolved.
Posted about 1 month ago. Aug 18, 2017 - 15:38 EDT