Elavon Credit Card Processing
Incident Report for ShopKeep
Resolved
Elavon transaction processing has returned to normal and all issues have been resolved. We will continue to monitor the status for continued performance.
Posted 12 days ago. Aug 06, 2019 - 16:43 EDT
Identified
Elavon is currently experiencing intermittent connectivity, meaning you may see issues processing credit card payments on their platform. All other platforms are currently processing successfully. Please subscribe to updates on this page for new information as we uncover it.
Posted 12 days ago. Aug 06, 2019 - 16:24 EDT