FreedomPay Gateway - Degraded Performance
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 20:49 EST
Identified
One of our credit card processing gateway partners, FreedomPay, has identified an issue on their end with transaction latency and processing timeouts through First Data and AMEX Direct and are currently working towards a resolution.

Merchants processing on this gateway may experience degraded performance when running AMEX cards during this time.

To keep updated with their progress, please subscribe to this page.
Posted Nov 18, 2022 - 20:39 EST
This incident affected: Payment Processing (Credit Cards).