Shopkeep Support
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 10:59 EST
Investigating
Shopkeep support will be undergoing a service update Wednesday December 16th between 10am-11am EST. All Phone lines will be unavailable during this time and are expected to be restored ~11am EST. For all immediate inquires during this time please email support@shopkeep.com.
Posted Dec 16, 2020 - 10:21 EST
This incident affected: Support (Phone).