Credit Card Processing - Clover
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 00:02 EDT
Identified
Our downstream partner has identified the issue with their vendor. We are working with the our partner to full service as soon as possible and will report back soon. Please subscribe to updates on this page for new information as we uncover it.
Posted Jun 09, 2020 - 20:40 EDT
Investigating
Some users are reporting an inability to process credit card payments using the Clover platform. We are investigating the issue and its potential cause(s) with our downstream partners. Please subscribe to updates on this page for new information as we uncover it.
Posted Jun 09, 2020 - 18:38 EDT
This incident affected: Payment Processing (Credit Cards).