Dymo Driver 8.7.3
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 15:19 EDT
Monitoring
Dymo has released an updated Dymo Driver version, 8.7.4, that resolves the issue of labels printing blank on the latest Windows Update. Visit https://www.dymo.com/en-US and select the driver download link from the banner at the top of the page in order to install this update.
Posted Mar 18, 2021 - 12:53 EDT
Update
We are continuing to investigate this issue.
Posted Mar 12, 2021 - 15:25 EST
Investigating
Dymo support has made us aware of an issue affecting the most recent Windows Update and Dymo Driver 8.7.3, the recommended driver for use with ShopKeep. Affected users when printing will find that their labels are blank. As a workaround while DYMO works to resolve, they recommend using an older version of their DYMO software, which is version 8.5.4.
Posted Mar 12, 2021 - 15:24 EST