Phone outage
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 03:20 EDT
Investigating
ShopKeep Customer Care is currently experiencing issues with phone and email systems. While we are working to resolve this issue, please use our Chat support.
Posted Jun 03, 2020 - 02:38 EDT
This incident affected: Support (Phone, Email).