Clover Gateway Outage

Incident Report for ShopKeep

Resolved

This incident has been resolved.
Posted Jul 19, 2022 - 20:53 EDT

Investigating

We are currently investigating an issue with one of our Gateway suppliers.
Posted Jul 19, 2022 - 17:48 EDT
This incident affected: Payment Processing (Credit Cards).