FreedomPay Outage

Incident Report for ShopKeep

Resolved

This incident has been resolved.
Posted Mar 22, 2022 - 17:26 EDT

Monitoring

The issue has been identified. Please tap "Get Updates" from the register to resolve.
Posted Mar 22, 2022 - 15:48 EDT

Update

We are continuing to investigate this issue.
Posted Mar 22, 2022 - 14:55 EDT

Investigating

Investigating - FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Mar 22, 2022 - 14:10 EDT
This incident affected: Payment Processing (Credit Cards).