BackOffice - ShopKeep
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 17:13 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2019 - 16:07 EST
Identified
The BackOffice is currently experiencing degraded performance regarding Transaction Reporting. We have identified the issue and we are working to resolve this as soon as possible. Please subscribe to this page for further status updates.
Posted Dec 14, 2019 - 15:41 EST
This incident affected: BackOffice.