Loyalty
Incident Report for ShopKeep
Resolved
This incident has been resolved. Merchants can once again load, check and redeem points in Loyalty.
Posted 3 months ago. Aug 07, 2019 - 06:13 EDT
Identified
Some merchants are currently unable to load, check or redeem points. We have identified the issue and we are working to resolve this as soon as possible.
Posted 3 months ago. Aug 07, 2019 - 05:59 EDT