Credit Card Processing
Incident Report for ShopKeep
Resolved
This issue with our partner FreedomPay is resolved and full connectivity to the payment gateway has been confirmed. All customers should be able to process credit card payments normally.
Posted 4 months ago. Jun 10, 2019 - 09:14 EDT
Identified
Our payment gateway partner FreedomPay is currently experiencing intermittent connectivity, meaning you may see issues processing credit card payments. We are working with the gateway to restore full service as soon as possible and will report back soon. Please subscribe to updates on this page for new information as we uncover it.
Posted 4 months ago. Jun 10, 2019 - 09:01 EDT
This incident affected: Payment Processing (Credit Cards).