S-Series Support - Phone Line Down
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 17:39 EDT
Identified
The S-Series phone line is currently experiencing an outage. Please contact us using our online chat service via your register, BackOffice or support website - https://shopkeep-support.lightspeedhq.com/support/submit-a-case
Posted Jun 13, 2023 - 15:34 EDT
This incident affected: Support (Phone).