Customer Care Phone Support - Investigating
Incident Report for ShopKeep
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 19:25 EDT
Monitoring
We are continuing to monitor the regional ISP outage affecting some members of our Customer Care Team. During this time you may experience extended waits on our phone channels. For more immediate assistance please use our chat option by selecting Help in your Backoffice.
Posted Apr 27, 2020 - 15:32 EDT
Investigating
We are currently investigating a regional Internet Service Provider outage affecting some members of our Customer Care Team. During this time, you will experience extended waits on our phone channels. For more immediate assistance please use our chat option by selecting Help in your Backoffice.
Posted Apr 27, 2020 - 13:42 EDT
This incident affected: Support (Phone).